Cerim Armor Set Upgrade Bug

Good day!

Cerim armor set which comes as the EA reward is set to tier 1 and level requirement is 21. When you try to upgrade it at the blacksmith the armor value doesn’t increase. I’ve tried only two pieces of the set and the issue is the same. I didn’t want to waste my resources but it must be the case with the other two pieces as well.

https://youtu.be/Q5V2f9VcrcA

2 Likes

Same issue, also tried two pieces before I realized there was no increase :frowning:

Thank you for the report!

Is there any update?

I believe the only bug here is that Cerim armor is marked as a tier1 item, while it is in fact a tier3 item already (based on the armor rating and that it requires lvl21), so any upgrade up until tier3 nets zero beneficial results. My guess is if you upgrade it to tier3.1 or higher it will get stat upgrades. (I haven’t tried though as resources are scarce enough already to experiment with this)

I cannot dare spending those material for experiment :frowning: whatever I already beat the echo knight. I am looking forward to new acts