Collection of 20+ bugs with logs, videos and screenshots

I decided to collect every non-fixed bug I’ve encountered so far (few of which I’ve already reported) into a single post for a more convenient overview.

I marked the game version when I first encountered each bug. For the record, this does not mean it was not present before. That’s just when I discovered it.

GAMEPLAY BUGS

Video:

  • Bugged Rune selection
    Using the item quick select menu with a keyboard and mouse bugs out the rune selection and allows the scroll wheel to change the selected Rune regardless of what menu you are in.

    I do not know if controller users are affected.

    First encounter: HOTFIX 2
    Still present in current version? YES

    Logs: (HOTFIX 2) Bugged rune selection logs.zip - Google Drive

Video:

I actually like being able to change my selected rune with the scroll wheel, but it shouldn’t be able to change while using the item quick select menu.

It screwed me over a couple times in combat when I changed my equipped food and it changed my selected rune as well without me noticing.

  • Floating frozen enemies
    If you freeze an enemy while they are in the air (for example during a jump animation), the enemy will float in the air and will not land until the frozen effect wears off.

    First encounter: HOTFIX 5
    Still present in current version? YES

    Logs: (HOTFIX 5) Floating frozen enemy logs.zip - Google Drive

    Screenshot:

  • Unable to move after defeating Darak in the Orban Glades
    After defeating Darak and watching the cutscene where he runs away, I was stuck in place for somewhere between 10-30 seconds before I could move again.

    I unfortunately couldn’t grab a recording of it in time.

    First encounter: HOTFIX 1
    Still present in current version? UNSURE (I tried, but I’ve not been able to replicate it yet)

    Logs: (HOTFIX 1) Stuck after Darak fight logs.zip - Google Drive

VISUAL BUGS

Video:

Video:

  • Bugged foliage physics(?) in Sacrament
    A lot of the bushes and flowers in Sacrament glitch out, stutter and pop out of the ground? I don’t really know how to describe it, so just watch the video.

    First encounter: HOTFIX 4
    Still present in current version? YES

    Logs: (HOTFIX 4) Foliage bug logs.zip - Google Drive

    UPDATE: This has been partially fixed in PATCH 1 (outside Caroline’s Inn), but it still persists in the other location showed in the video.

Video:

  • Fog flash in Echo Knight arena
    I was standing in the entrance to the Echo Knight arena when this bug happened. I was AFK’ing there for a few minutes because I was dealing with something else unrelated to the game.

    Then I noticed that the fog suddenly got really bright. It wasn’t quite a flash, but it’s the best way I can describe it with how quickly it became so much brighter.

    First encounter: HOTFIX 4
    Still present in current version? UNSURE

    Logs: (HOTFIX 4) Fog flash logs.zip - Google Drive

    I couldn’t record it, but I managed to grab a screenshot of it:

  • Misaligned animation in Cerim Crucible
    When offering a Fallen Ember, the animation might not line up with the altar depending on how the player is positioned when the animation is triggered.

    This could be fixed by making the character turn towards the altar after the player interacts with it.

    First encounter: HOTFIX 3
    Still present in current version? YES

    Logs: (HOTFIX 3) Misaligned offering animation logs.zip - Google Drive

Video:

  • Enemy character remains after exploding
    That one infected enemy that explodes and releases several leeches doesn’t always disappear after exploding. Sometimes the character model remains stuck in the standard A-pose with no collision.

    From a gameplay perspective, the enemy is dead, it doesn’t do anything. It’s purely a visual bug with the character model.

    First encounter: HOTFIX 2
    Still present in current version? UNSURE (last time I encountered it was in HOTFIX 4)

    Logs: (HOTFIX 2) Bugged enemy character model logs.zip - Google Drive

    Screenshot (from hotfix 4):

Video (from hotfix 2, this one specifically exploded in a scripted sequence):

UI BUGS

  • Can’t use spacebar in the Watcher’s inventory upgrade menu
    After selecting which inventory I want to upgrade, I can no longer use the spacebar to go through with my selection.

    Left mouse click still works fine.

    I also encountered another bug here at the same time where I had the main hand weapon upgrade selected, but it upgraded my misc inventory.

    After selecting the main hand weapon upgrade, the game asked me if I’m sure I want to upgrade my misc inventory. I clicked yes because I didn’t realise what the prompt said in time. So it seems like it prompts you with the wrong upgrade after your selection.

    I unfortunately couldn’t catch that second bug on video.

    First encounter: HOTFIX 5
    Still present in current version? UNSURE

    Logs: (HOTFIX 5) Inventory upgrade menu logs.zip - Google Drive

Video:

Video:

OTHER BUGS

  • Table in Caroline’s Inn doesn’t have collision
    The table in the corner in Caroline’s Inn (tier 3) doesn’t have collision and you can walk through it.

    First encounter: HOTFIX 4
    Still present in current version? YES

    Logs: (HOTFIX 4) Table collision logs.zip - Google Drive

Video:

  • No music in player house
    Sometimes the music in the player’s house doesn’t play. Happens about 60% of the time. In hotfix 5, I also heard rain sounds in the house.

    First encounter: HOTFIX 4
    Still present in current version? YES

    Logs: (HOTFIX 4) No music in house logs.zip - Google Drive

Videos:

PERFORMANCE

Hotfix 5 made some minor improvements, I got an extra 5-10 frames and I really appreciate the work the devs have been putting in, especially with how quickly they’ve been pumping out these updates!

Unfortunately, the game still doesn’t perform that well for me overall, I’m getting 30 FPS on average, and sometimes it dips below that in certain areas.

I’m also still experiencing horrible model pop in when entering new areas. This got much better in the Nameless Pass with hotfix 5 (only the tiny objects pop in now, the terrain no longer pops in!)

First encounter: HOTFIX 1
Still present in current version? YES (but there have been small improvements!)

Logs: (HOTFIX 5) Environment pop in logs.zip - Google Drive

Video:

PC specs:
Windows 10
Intel Core i5-10400F CPU @ 2.90GHz
RTX 4060 Ti
16 GB RAM
1080p @ 60Hz
The game is installed on an SSD and I have the newest NVIDIA drivers.
Graphics preset is set to performance.

Hope this helps squishing these bugs! I’ll keep this post updated in case I find out more about some of these glitches (like how to replicate them).

1 Like

Wow this is great. I am sure they will apreciate the effort.

Wow, thank you! We’ll make sure these get fixed up! :+1: :heart:

5 Likes

Thank you for the response and for all the hard work the team has been putting into this game! :heart:

1 Like

Hi, about your first raised bug. It happens whenever you die while teleporting. You can easily reproduce it by trying to teleport with enemy being around targetting you.

Let me know if you need any files or more informations.

1 Like

That makes sense. But as far as I can remember, I didn’t have any enemies near me, which is why I’m puzzled as to how it happened in my case.


With all resources in place, construction does not begin.

Standing models of mobs.

Problem with drawing the bridge. It’s like this almost every time.

What program are you using to show Inputs in-game?

I use NohBoard but it’s ugly. Curious if yours is easier/better than NohBoard. Thanks.

I’m using an OBS plugin called Input Overlay

1 Like

Thanks. Dang. Does it have a Desktop version? I use a Dual PC setup and OBS is on the Stream PC.

Idk, I only use it for recording. I’d check the forum or the github page.

Great job. For me the cannons in the crucible are all just going “Boom” without actually shooting. Do they actually have animations for you?

1 Like

Not since Patch 1, which broke ALL the cannons. Previously, they all worked fine except for the one in my recording.

The consequence, lol.