Virus and missing files. cannot return to game please help

After talking to the guy for entitlements, I walked towards the respawn and all of a sudden it kicked me out of the game. see attachment with virus notification.
After restarting the pc and clearing the virus, uninstalling, and validating files, the game will not open.

How can i fix this?

Had this exact issue. If you are able to whitelist the file that is best. However launching steam as an admin fixed it for me. I believe your windows defender is marking the executable as a trojan.

1 Like

Thanks for the reply but the admin strategy did not work. I am scared to whitelist it because i dont know anything about computers. this pops up everytime from windows defender: Trojan:Script/Wacatac.B!ml

On the discord moderators have stated it is safe to do so. Whitelisting seems to be your only option. It is up to you if you trust the company.

If you have booted up the game before, you have run the EXE and all associated files before. It is, by the discord mods word, not a virus, simply a mistaken “identity”.

I installed it on my laptop and it seemed to run without any problems. Any idea why my lap top that has windows 10 works and my desktop that also has windows 10 doesnt work?

Because you have different settings for Windows Defender and one of your computers is blocking the executable and one is not

Can you explain why it happened randomly while I was in the game? This is after I updated and I am in the game longer than an hour. The game was working fine up until now

I’m not an expert, but it’s likely the executable accessed something in memory while you were playing and it tripped up Windows. It’s still an issue/bug with the game, but if you can figure out something with your Windows Defender (if it’s even still called that) you might be able to provide a bit more info for the devs so they can reproduce it.

I mini patch came out and I think it fixed it!

1 Like

So I just got this with newest patch about 30 minutes ago and smart access app on win11 is blocking this game. I have whitelisted it and everything but without disabling smart access I now can’t play now. Any thoughts or fixes incoming it says its a trojan virus.

(updated) this has not been fixed. I sent feedback to microsoft to look into this. I’m hoping this will be fixed. I tried uninstalling the game, I have allowed the trojan through defender and smart control app still says no way. Not sure what to do, I enjoy this game, I would like to play :frowning: .

Just in case anyone’s still having an issue with this:

Virus & threat protection > Protection history > It’ll say either Threat blocked or Threat removed or restored, click on that > then Actions and either Allow or Restore the ‘threat’ (double check the file you’re allowing is actually NoRestForTheWicked.exe)

1 Like

thank you for the response. I had restored the threat and it is still being blocked by smart access control app. I have uninstalled the game, reinstalled the game, it will not let me play it. The only way I think it will allow me to play the game and bypass the Trojan is to disable the smart access app. what do you think??

You could try adding the game .exe to Windows’ exclusion list? I’m still on Windows 10 so I don’t have Smart Access Control but I’ll do what I can to help

thanks again for the response. I added it in the exclusion list. it still won’t launch. same app blocking it. When I looked into the error further through steam the error has something to do with the .EXE not being a verified signature from developer. What I’m figuring is steam dont trust the developer due to the signature not verified which is triggering the smart access app. I’m assuming, it’s something to do with the update I got a few hours ago for the game update 2. I’m assuming.

Yeah I did some googling just now and there’s no option to allow specific apps in Smart App Control and even Microsoft themselves suggest turning it off (until the dev signs their app with a valid signature). So I’d imagine turning it off will let you play without any issues and if you really want you can always turn it back on when you’re finished until Moon fix the signature

It’s weird, just now I verified the files for the fifth time a now it corrected the issue and now the game launches. holy crap, I have no idea why now all of a sudden. I’m sure they verified the signature. Thank you for the help and concern.

1 Like