Blacksmith cant Upgrade my Weapons and Armors

Issue: Can’t upgrade weapons and armors in Blacksmith

Description: Can’t upgrade weapons and armors in blacksmith, the UI to upgrade the items is missing, see filename “filBug_0.png” in the google drive. I’ve also added another image named “filBug_1.png” for a “happy path” scenario for the upgrade test case.

I don’t know if this is relevant, but I’m playing the game via my PC then streaming it to my Steam Deck via Moonlight, I’ve tried the game natively on my Steam Deck to check if the bug is also present there, and it was.

I didn’t try to restore the realm because I’ve made progress in the end-game rougelike.

Steps to Replicate: There are several thing that I’ve done prior to noticing this bug, one of these might be the correct step to replicate

Scenario 1
Filimore is Level 2

Step 1: Upgrade Filimore to Level 3
Step 3: Check if you can upgrade your gear

Scenario 2
Filimore is Level 3
10 items in gear inventory

Step 1: Purchase several “Blood-Rusted Sword”
Step 2: Sell all “Blood-Rusted Sword” that has an attack value below 7
Step 3: Repeat the buy and sell process until gear inventory is full
Step 4: Enchant all “Blood-Rusted Sword” purchased (Enchanting Vendor is lvl 3)
Step 5: Sell all enchanted “Blood-Rusted Sword”
Step 6: Repeat Steps 2, 3, 4, and 5
Step 7: Check Filimore(Blacksmith) if you can upgrade your gear

I have not seen any posts related to this bug.

Useful Links:
https://drive.google.com/drive/folders/1Qb2EawaSexI_ArEwZtcw3MmXnoyEAM7N?usp=sharing

Template Used:

Thanks!

2 Likes

Update on this: I tried restoring realm, creating new realm, and creating a new character. None of them work, I still can’t upgrade.

Another possible suspicion is going inside the rookery before the cinematic with the old man and the apprentice on top of the rookery gets triggered. What happened is that the cinematic triggers while you’re inside the rookery.

Many thanks!

I have upgraded Filimore to level 3 and have also bought many items, enchanted them and then sold them, but I can still upgrade things, so it might be related to something else.

Does this work even when you have the required materials ? I see in your screenshots attached you have none of them?

image
image

I cant upgrade currently, have him a Level 3 as well, it wont even show me the requirements

Can you attach a screenshot or video for further investigating?

I put up an image, it changed my cerim to T1, goes up in color like its being upgraded, but the armor value didnt go up at all and again cant see any of the requirements for anything

Hey Caiden,
Wanted to update, the ability to see the upgrade items came back, but I literally had to upgrade the cloak all the way back upto Tier3 before it started giving me armor increases. I’m assuming that is a bug, that a level 21 restricted item would be showing at Tier 1 and force you to spend a crazy amount of resources just to get meaningful upgrades

Here is an image of my Cerim Hood that I didnt do anthing too, you can see its T3 and still also doesnt so requirements

Here is the same downgrade issue on the Cerim legs, it acted like it upgraded, but did nothing but change it to a 1, and lower the cost to 10 copper. Gave a full screen image so you can verfiy im at the smithy. Hopefully this can get figured out

Damn, so this is what lack of sleep does to a man, I could’ve sworn there was a UI on the right side of the Upgrade Menu, but you’re right, upgrading does in fact, work.

I do apologize for being unaware, all the best for you and your team. Thanks for providing us with this gem of a game.

1 Like

any luck with this? i’m experiencing the same. the UI showing needed mats does not even appear.

UPDATE: it seems to work off and on. went back after doing some inventory mgmt at chests, and it works.

Yeah I had to exit out of the game to desktop and back in to get it working again, however the deleveled equipment was the biggest shock, and still is busted

1 Like

Encountered the same issue, can’t upgrade my shield further. It simply disappeared from the Blacksmith’s tab as soon as i upgraded it last.

I have a different issue where fillmore is just lvl 3 and after some upgrading I can’t do it anymore. Even though the materials listed are in green in my inventory and I have enough money to do so