Post about performance issues [WITH A POTENTIAL FIX INSIDE]

Hey! Nice game. I really like the VFX and SFX and attention to detail. Truly an immersive world and the gameplay is giving with more and more depth when you didn’t expect it!!!

However it is unplayable. For 20 minutes on a fresh PC session, game runs just fine and normally as you would expect from a game developer.

Now I noticed a pattern that happened in a few sessions spaced between each other. Always after 20 min the game suddenly becomes unplayable. It starts to lag in places it didn’t and frames drop forever. At that point I just quit the game . Issue is not caused by any overheating.

Taking into account all basic troubleshooting options, I can say that this is 100% a memory leak issue. I don’t know where it is and if you knew about it.

If you didn’t know about it, then I hope this post will help you pinpoint the exact issue and try and fix it asap!!

I’m sorry I couldn’t be of more help, I am trying my best to simply enjoy a product I bought on Steam.

2 Likes

I have a 5700 xt from AMD and my game has this stutter every 20 seconds. Changing the game to Balanced mode helped alot now it happens every 60 seconds. I hope the devs figure it out!

1 Like

Thank you for your response. It is heartwarming to see another player with the same issues. I know, because I have been recently on a gaming spree, where titles like Diablo IV, Elden Ring have not cause any issues to my machine.

I think the devs will be able to figure this out, but it is important we voice our concerns so they can fix it.

I found a temporary solution that allowed me to enjoy another 35 minutes of uninterrupted gameplay of this game. It’s really good when it works!!!

The performance fix is tweaking the boot config in the game directory to these settings. I will explain some of them below.

gfx-enable-gfx-jobs=0
gfx-enable-native-gfx-jobs=0
wait-for-native-debugger=0
hdr-display-enabled=0
gc-max-time-slice=5
build-guid= // Don’t change this

In Steam click Manage files or Open Local Files (Find where NoRestForTheWicked is installed. Then inside the folders look for a small file called “boot” or “boot.config”. Inside you will see a few settings with the number 1 at the end. Change it to 0.

These are some supplemental settings that developers seem to have been trying out before. Setting them to zero disables them and this has lead to improved reliability of the game.

Another important setting is:
gc-max-time-slice=5

Which increases the window the game uses to focus on garbage collecting, in effect reducing over spent memory allocations. It all sounds good to me. I’ve been able to fight more efficiently and enjoy the cool scenery, effects and details of the game. I hope to enjoy more and that we can forget this initial mishaps with the game! Have a nice day!