Crucible quest Broken

Apparently the Crucible thing is broken for me.

I reach Elsa at the Masonry but the says “It may take some time before this chamber will yield its secrets. History compels patience”

i have fallen embers, i killed the twins. I saw on youtube i should get to the altar and to the blood sacrifice but nothing happens


1 Like

This is happening to me, too. :frowning:

It seemed like the tome you’re supposed to give her wanted to go into the bag that stores your runes, but mine was full. The tome fell on the ground when the apprentice mage gave it to me (instead of going into my inventory).

When I tried to pick it up, it ended up going to my “key items” (the last inventory tab) stash. I get the same “it may take some time” message as you, now.

For me the solution was to create a new realm and get to the same point, in that case the quest activated correctly. Not ideal but in the new realm you can go through mobs easily being over-leveled

Same problem here, I think we need to wait a fix.

I would suggest to create a new realm and rush to that quest. Being over-leveled makes things easier. The only issue is the crane might not rotate and once you get used to have the stairs you forget how you originally got into places

Go to realms and check if your realm has a backup savedata, reload an older save in wich you don’t have the tome, I was able to fix the glitch.

For me it worked at first and I was able to enter the dungeon.
After Hotfix 4 however it stopped working and I can not interact with the statue anymore.
Reverting saves also did not help.

We have our QA Department Investigating the Issue. Thank you for your report!

I’d like to add that this happened to me too out of nowhere at the later stage, with the altar that controls the elevator

I found out what triggered the bug for me, dieing on the second stage bugs the altar

After today’s update (Early Access Patch 1), I’m facing the same bug. When i want to re enter the crucible, i cannot interact with the statue anymore.

This is happening to me, too.

I created a new realm after this happens, then rush to the quest, but it still happened.

Even if I’ve reran quests after deleting all realms and characters, it still happens.
And now my cerim armor set is gone.