HDR not working at all (AMD Radeon)

Hello there. HDR is not working at all on my computer. Looked on the forum and on steam and they say it works in fullscreen windows, that you have to delete grayed out monitors from device manager (not sure how this would help in any way, if you know how windows manages drivers and devices, but I still did anyway), and so on but it just doesn’t work. The picture is totally washed out and looks just awful.

I am using a Radeon RX6800, on a LG Ultragear 48GQ900 OLED Monitor connected on Displayport to my rig. I don’t have this issue in any other game or HDR content. AUTO HDR works correctly with every other game such as Cyberpunk or Elden Ring or even Youtube.

Seems like it doesn’t work at all on AMD, it seems that everyone who got it working by messing around was on Nvidia. I cannot find any post by AMD GPU users who have HDR working.

Btw, I also tried to messa round with bpc, color output settings (switching from rgb to YCbCr, using an HDMI cable instead of DP) nothing, and yes, I am on the latest AMD driver (24.4.1) on Windows 11 (fully updated).

I’m playing in HDR on RX6900XT just fine. All it needs is enabled HDR in Win 11 specifically for that HDR monitor (I have three others without HDR support) and enabled HDR in the game itself. The game must also start on that monitor in HDR mode. If it starts on another one, I press alt+enter, move the game window by dragging its caption to my HDR monitor and alt+enter again to full screen window. Then it’s remembered and next time it starts right where I left it. Game should allow you to enable HDR support in settings. If the image doesn’t look HDR, pls exit the game and start again. Pls note the exclussive fullscreen doesn’t support HDR correctly now. It looks like a Unity bug that we are investigating (the swap chain is not created for HDR). You must be using windowed or fullscreen window (without caption)

Hey there, thanks for your reply. I tried every combination, can’t get HDR to work at all :frowning:

Not by enabling HDR system wide before launching, not by launching without HDR and then trying to enable in-game (button is not active), not in fullscreen, not in windowed, not by changing after launching, not on HDMI, not on DP. I have only one monitor, the LG 48xxx.

HDR works just fine in other games like Elden Ring, or Cyberpunk. I also reinstalled Ori and the Will of the Wisps and HDR works in that one just fine.

HDR support in No Rest for the Wicked (NRftW) is done exactly like in the Ori: WotW, where it works for you. Are you using the same resolution? HDR requires additional bandwidth. Maybe it’s your cable limitation if output resolution is much higher than in Ori. Also, you started this thread by mentioning Auto-HDR. That’s for games without HDR support. AMD driver si doing all the work and you shouldn’t use it for NRftW or Ori:WotW. Both have their own HDR implementation. But the fact it’s also not working is another hint it must be some HW limitation, possibly the high output resolution or some other settings you’ve made in the AMD Catalyst™ Control Center specifically for NRftW

I was about to prove to you with a video that it works in Ori just fine at 4k 120hz, so I booted it up and like I said it worked just fine in Ori. Took the video, closed Ori and launched Wicked, and… HDR was working flawlessly there too for the very first time since I got the game.
I don’t understand! I changed nothing since I made this post. Oh well, I’m just happy that it works now.

1 Like

I’m glad it’s working now!