Game crashes on entering realm with intel arc GPU

I believe this is due to having an intel arc GPU due to someone else in the discord server with an intel arc GPU having the same issue. I am unable to grab a screenshot but when I press continue on the main menu and the game goes to the black loading screen with the red gem in the bottom right hand corner, it stays there for a few seconds then the game crashes


Same problem with ARC 750

1 Like

Same here - Arc A770 GPU, game crashes to desktop upon trying to start or continue a game.

1 Like

Same, Intel Arc A750

same problem but im using an AMD RX6700XT

Has anyone been answered by the devs regarding issues with ARC graphic cards?

Same for me. I have A770M since I am using NUC12SNKi7.
As soon as realm loads it crashes to desktop.

I’ve got an a770 16gb with same problem but I saw some people say it works now with latest patch and latest drivers ( which was released yesterday. I have not tested it yet because I already refunded the game… Would be nice to hear from more people if that’s true, before I purchase the game…again

Same issue. I just updated the game. Intel arc A750 current driver version is seems to be the lastest for the gpu. Still game begins to load realm music comes through only black screen and then crash. I’ve turned off motion blur, set graphics option to performance reduced sharpness and render still getting crashes. I did confirm through family sharing that this seems to be happening when trying to load the realm for the first time. Not sure if it’s a cutscene or what but I was able to load a family members character and realm just fine.

There is a newer driver 5444 that resolves the crashes, but for me still has missing textures and other issues ^^

I havent gotten an answer yet


Hey! There’s a good chance this is a driver support issue with Intel Arc but we’re looking into it and will update once we get more information

1 Like

Ty for looking into it

Game stopped crashing when loading realm after updating to latest arc drivers for me.

Still get ocational crashes when playing though, mostly when entering another room. But atleast it loads into realm now.

Do you still crash when using the latest ARC driver?

Same goes for anyone else with an intel arc card?

If you do, it would be great to have the following:

  1. Where do you crash?
  2. Send your DXDiag, which driver version you are using, if rebar enabled in bios