Feedback about Optimization

PC: Windows 11 Home
RTX 3080 12gb
Intel i7-12700K
Ram: 32gb DDR5

Graphics settings: quality
Motion blur: 0%

FPS: 25-35 at the beginning of the game

I use balanced settings. I’ve had my fps locked to 90. Haven’t tried any higher than that, just thought it’d be a good starting point. I’ve have about 3 hours played so far, and haven’t noticed it dip below 90 at any point outside of the title screen (where it seems to be locked to 80). Aside from some shader compilation stutter when I enter a new area for the first time, I’ve been pretty relieved with the good performance I’m getting. I was expecting much worse.

My specs for reference:

OS: Windows 11 pro (Version 22H2, build 22621.3447)
CPU: 13700k
GPU: 2070 super (Driver version 551.34)
RAM: 32gb ddr5 6000MHz (CL30)
Storage: Samsung 990 pro NVMe
Monitor resolution: 1920x1080p


Display mode: Windowed borderless
Vsync: Off
Fps Cap: 90

Quality presets: Balanced
Render Scale: 100
Motion Blur: 100
Framerate Independent Motion Blur: On

Dynamic Resolution Scaling: On
Target FPS: 90

I haven’t tried turning dynamic resolution scaling off or anything. All I did was set an FPS cap and change the presets to balanced. Maybe having an SSD is more important than you’d think? Not sure.

Have you updated your GPU drivers? Think Nvidia released a driver update to help with performance within the past few days. My drivers haven’t been updated since december, though, so ymmv.

Hope you can figure out what the issue is.

1 Like

Duuuuuude how are you getting such high frames!?

These area my specs:

Razer Blade 15 Base Model (Early 2020 Model) RZ09-0328

4K OLED Screen
NVIDIA GeForce RTX 2070 with MAX-Q Design (8 GB of VRAM)
Intel Core i7-10750H

I’m playing at 1080p on balanced settings with motion blur off. I’m getting low FPS and stutters from time to time when more things load in.

1 Like

D: I honestly have no idea. I was surprised to see people were having performance issues when I decided to check the forums after playing for a while. I was expecting the worst.

I think 4k resolution is prob the issue here, 8gb of vram is quite low to be playing in 4k (with this card in particular). I’m only at 1080p, so my CPU is doing a lot of the heavy lifting.

Since the game doesn’t seem to complile shaders at launch, some compilation stutters are to be expected. Hopefully it gets ironed out with time. I haven’t had it impact my gameplay outside of a half second of hitching when I enter a place I’ve never been before.

I hope the issues get solved for you guys. This game is fun, and it really blows that the performance is detracting from people’s experience with it. :frowning:

1 Like

Windows 11
RTX 3060 12GB
Ryzen 7800x3d

Graphics settings: quality
Motion blur:0%
Resolution Scaling: OFF(!)

FPS in game 70+ :slight_smile:

1 Like

Guys, I also played with the graphics quality settings, but it didn’t help me in any way. I played about 20-100 fps (depends on the location, for example in the alchemist’s dungeon fps increased significantly), but my surprise began when I reached the location of the city and my fps dropped to values 5-15 (THIS IS NOT A JOKE, as the scene with the Inquisition was ALL 5 fps).

I’m playing with settings like everyone else, but the resolution is selected 2k, maybe that’s why, I’ll try to change the resolution.

Also I’m not quite sure what values to set in (Scaling), I set both scaling to 100%

I’ll try reinstalling the game on the SSD, but I don’t think it will be critical for the game. Still, the optimization in the game is very bad, constant fps drops depending on the location is proof of that (which are found literally in the next room).

But if you turn off scaling, then the quality is absolutely terrible, harm to the eyes at least:)