Bounties bugged after latest update

I can’t turn in a bounty I already completed (Within Our Walls) because when I press A to turn it in the game asks me if I want to replace it. I’ve been doing this bounty in different realms and this just started happening today. Today, the first time I pressed A to turn it in, I pressed A again instantly because I was used to doing it quickly, but it said replace bounty instead of turning it in, and the bounty disappeared (and nothing actually replaced it). I made another realm to do the same thing and it keeps happening, I just can’t turn it in because it wants to “replace” it.

9 Likes

I am too having the same issue with bounties. It is asking me to replace the bounty instead of turning in. I tried the same thing in another realm too same thing happened. I can’t turn-in bounties only, but challenges are still working.

1 Like

Same for me, bounties and challenges :frowning:

1 Like

challenge is actually still works. it written replace, but you still get the reward

Same here, but if you click “Yes” you still get rewards. So it works, but the screen shouldn’t be shown if you want to turn it in as completed.

1 Like

Same issue here… I can´t take the rewards! please fix it!

I have the same issue after 4th hotfix.

Jotting my name down as well for this one.

For Bounties, No reward seem to be given.

I had this issue but, pressed A anyway and got my reward.

Rewards AND experience?

Same here.

Link to wetransfer-data: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

Thank you all for the reports! Looking into this now

1 Like

Label is wrong, have same problem it say “Replace” but it will complete the mission

1 Like

It definitely doesn’t complete it for me, I looked specifically for the bounty rewards and nothing

I’ve got a question: Do unfinished bounties disappear after a while from your quest-log? Mine (the bugged one) is gone today.

Same here. Just killed the dude in the war room and tried to turn it in. Only option was replace and now its lost and I didnt get any rewards for it. Very cool

same, I cannot turn in bounties :((