KB/M bugs (current as of PATCH 2)


The feedback/refactoring part is here

  1. using the following key rebinbds via mouse+wasd layout:

    • forward/left/backward/right → Space/D/S/G
    • food → C
    • run+dodge → F
    • sneak → A
    • gestures → P

    then after the game’s restart:

    • the game will show backwards as unbound if you visit rebind menu
    • it seems everything works fine though, but the game will pester you to fix “missing” keybind if you change something else
  2. special/symbol key rebinding issues

    There are 5 potential things:

    • incorrect in-menu display
    • incorrect in-game display
    • doesn’t work
    • rebinds different key
    • shows differently after returning to keybind menu

    if I don’t mention one of the above => that one is ok

    Discovered issues so far:

    • \ in-game as yellow A-ish, doesn’t work
    • = in-menu as +, after returning to menu in-menu as yellow A-ish
    • ’ in-menu as ", in-game as ~, in reality rebinds backtick (`)
    • ` in-game as yellow A-ish, doesn’t work
    • capslock in-menu as yellow A-ish, and in-game as nothing, doesn’t work, after returning to menu action is unbound
    • . in-game yellow A-ish
    • , in-game yellow A-ish
    • / in-game yellow A-ish, in reality rebinds numpad/
    • numpad/ in-game yellow A-ish
    • numpad* in-game yellow A-ish
    • numpad- in-game yellow A-ish
    • numpad. in-Menu yellow A-ish
    • del in-game yellow A-ish
    • insert in-game yellow A-ish
    • pgup in-game yellow A-ish
    • pgdown in-game yellow A-ish
    • [ ] - ; numpad+ numpadEnter home end backspace - these seem fully ok

  3. RAlt formally not recognized but working:

    Both left and right alt are recognized by the game as the same key, but in the rebind menu you cannot use RAlt (you can use LAlt and both will be recognized as just Alt key)

  4. If Alt, Ctrl or Shift is used for some actions (e.g. moving, offhand use) …
    … it will not work correctly as a combination with other actions. For example:

    • if you have ‘move forward’ under Alt, it will not work with run/dodge under let’s say K
    • if you have ‘offhand use’ under Ctrl, it will not work with toggle runes under let’s say B
    • if you have ‘move left’ under Shift, it will not work with attack under keyboard’s key, say N

    The above list is just few examples, it’s not exhaustive.

  5. non-rebindable keys:

    • all 0-9 numpad keys, please don’t forget those
  6. Key currently bound to dodge is prompted in-game as a conversation line skip.

    The side effect of that is that if you talk to a secondary NPC without its own menu, skipping the last line will execute dodge.

  7. ‘R’ key under “mouse and wasd” layout is hardcoded to parry

    It can still be assigned to other functions and will then call BOTH of them, starting with parry.

  8. Target juggling (in indeterminable fashion) is hardcoded to MWheel up/down

    • this action should be rebindable (see the link at the top how to improve the functionality)
    • MWheel up/down should be rebindable as well
  9. (patch2 new) Under “mouse and wasd” layout, binding Interact action doesn’t automatically unbind conflicting keybinds (and vice-versa)

    Depending on context, one of - or - both actions will be executed

  10. (patch2 new) The mouse+wasd layout now supports separate dodge/run, at least according to the keybind menu (or it’s just a side effect of some changes) - none the less binding dodge to a key other than run causes the dodge to not work at all and run to only function as run now.

    You can instantly reproduce this issue by:

    • reset this layout to defaults
    • bind dodge to B
  11. ‘V’ key under “mouse and wasd” layout is hardcoded to block

    This will conflict with potential rebinds, for example:

    • rebind ‘V’ to Rune 4 instant use
    • equip shield
    • equip 1h weapon with 4th rune slot used

    Some outcomes:

    • “wind of death” katana: block will take priority over katana’s twirl dash
    • torch having a return rune in the 4th slot: the rune will take priority over the block (unless out of focus)

    Similarly keybinding ‘shoulder barge’ to ‘V’ will have lower priority than hardcoded ‘block’ (reported earlier by @acralla).

  12. ‘F’ key under “mouse and wasd” and “mostly keyboard” layouts is hardcoded to drop

    This will conflict with potential rebinds, for example:

    • rebind ‘F’ to move right
    • try to move down

    You will drop down instead of moving down as usual. Reported by @Greg_Maddox.

Historical / seems fixed:

After restarting the game or changing realms, the game thinks keybinds are not changed (at least when using mouse+wasd layout). Entering keybind layout selection and switching layouts to something else then back to the original fixes the problem (usually, I had to rebind everything again once).

Return rune doesn’t work in layouts that rely on instant casting of runes (ITOW it only works in “mostly keyboard scheme”). This of course implies, that there might be other channeled runes that don’t work either.

F1-F12 keys and side mouse buttons are not rebindable


Is any of the Devs keeping an eye on this ? Do you need more details, maybe videos showcasing those ?

Or is this waste of the time ?

1 Like

I think posts like this are very valuable, however they do not really get discussed much since… there is nothing to disagree on :wink:

Go on


This. Just keep working.

My noticeable issues with keybinds is that Modifier keys like Shift, Alt and Control all seemingly have weird input ghosting/queue issues when used in conjunction with another regular key like V for shoulder barge or simply Interacting with E while holding Shift.

I changed my Sprint to Up Arrow and Rune Attack to Right Arrow and it helped some input issues. I still think performance is a major factor in input ghosting/queue issues but we’ll see with Patch 2 if performance helps solve some of those issues too.

Carry on.

1 Like

got related experience… Shoulder barge and rune atk not working

was working before on default keys… found RESET CONTROLS option and tried to rebind… “Customize control”, some buttons work on keybinding … some does not

after that, it messed up controls and the “Shoulder barge” and “rune atk” started NOT TO WORK

  • using “Shoulder barge” button V, does not do it, instead using offhand use “shield in it”
  • orange gauge is FULL, but rune atk tried the number button and or the assigned key, not working
  • tested all other KBM setting
  • changing buttons does not make the “Shoulder barge” and “rune atk” to work, tested multiple, not working

  • under “Customize control”, some buttons work on keybinding … some does not
  • RESET TO DEFAULT does not fix

I know according to dev, they are still working on key mapping… but for me to play properly at least RESET CONTROLS should make the “Shoulder barge” and “rune atk” to work again using default keys…

  • created a new realm… same issue “Shoulder barge” and rune atk not working



So i am playing on m/kb and found a set that works quite well for (by now approved by me) focus caster, meele tank and twohand wield, so… basically everything.

So i could share that maybe: :wink:
The basis is the middle sheme, “mainly keyboard”

movement: wasd
dodge: space ( it activates at button release though ! )
attack: mouse left
parry: mouse right
focus ability: mouse middle
use sidehand/block: alt left
use sidehand/shoot arrow: alt left + right mouse key (mouse somehow hardcoded)
shield push: q (this only works with heavy armor btw)
interaction: e
run to mouse cursor/run with keys: shift left
walk to cursor: B (only used if really necessary, e.g. on balancing parts)
sneak: ctrl left
heal: f
sidehand item: g
toggle runes: r (basically never used)
toggle auto target lock: t (basically never used)
toggle mainhand: x
toggle sidehand: c
inventory: i
journal: j
runes 1-4: 1-4 (also can be scrolled with the mousewheel)

feel free to copy and share :wink:

1 Like

Yea, for the time being using modifiers for anything seems like a bad idea. To add to the examples - when I had block under Ctrl, I couldn’t run to the mouse cursor.

My gut feeling is that the game interprets those as actual modified keys which are not bound, so any combination stops working correctly.

Overall, I had to rebind all special symbols and modifiers on keyboard level to make the game work consistently.


Tactical Cross-Link:

Added a funny rune bug. TBH I’m wondering if they have any actual testers.

Hey, thanks for your report! Answering your question about internal testers I can say YES - they exist :grin:

I walked through all your bugs and after releasing Patch 2 I wanna believe that most of them has been fixed. Some of them are not, but known: there may be different reasons to delaying its fixing. pls take that into account.

Your report still quite helped us, I reported 2 new bugs according to your found problems:

    • if you have ‘move forward’ under Alt, it will not work with run/dodge under let’s say K
    • if you have ‘shield block’ under Ctrl, it will not work with run/dodge either
  1. the game will show “backwards” as unbound if you visit rebind menu after restarting the game

Feel free too reach me if you find more bugs for remapping. Cheers!


Not that many are fixed TBH :thinking:, I’m going all over them now after resetting all layouts to defaults just in case, I’ll update the first post once I’m done and ping you.

Two new things I already found:

  1. mouse+wasd layout now supports separate dodge/run, at least according to the keybind menu (or it’s just a side effect of some changes) - none the less binding dodge to a key other than run causes the dodge to not work at all and run to only run now; you can instantly verify the issue by 1) reset to defaults 2) bind dodge to B

  2. binding interact to a key conflicting with something else does not unbind the conflicting key

Issues updated to patch 2.

1 Like

Control (CTRL) + Arrow Keys (Rune Attack Keybind) does not register.

1 Like

Yea, this likely falls into point 4 in the above list.

1 Like

I think I got something now lol.

Sneak/Drop Down = C
If rebound to X, Drop Down is Still C but Crouch is now X.

Can’t Discard using Keyboard (C) when in a Chest Inventory.
If Settings associated to C are rebound, Discard is always C.

Gamepad is capable of Discarding objects when in Chest inventories.

1 Like

Rune Attack Activates Sidle when near a wall regardless of keybind
(Up Arrow and + sign were used in testing)

Yeah that’s because Sidle is higher priority in this case. It’s known and I also found more pairs like this, I hope we will fix them for the next update

1 Like

New “issue” as I only recently started messing with Shield.

If you Hold to activate shield (Keybind Down Arrow) and then tap Rune Attack (Keybind Up Arrow), the character will do a Normal Attack (Keybind LMB).

Hmmm, all rune attacks default to standard attack if there are no runes. If you meant ‘offhand use’ (down arrow) + ‘rune attack’ (up arrow), then this is what probably happened as you ‘offhand used’ shield and its rune-less.